Uploaded image for project: 'Marathon'
  1. Marathon
  2. MARATHON-8144

published plugin-interface 1.6.322 pom has wrong version

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: Marathon 1.6.322
    • Fix Version/s: None
    • Component/s: Build & CI
    • Labels:
      None

      Description

      In SBT, I defined a dependency on version 1.6.322 of the plugin-interface library:

      "mesosphere.marathon" %% "plugin-interface" % "1.6.322"
      

      However, when resolving the dependency, I get the following SBT error:

      [error] (*:update) sbt.ResolveException: unresolved dependency: mesosphere.marathon#plugin-interface_2.12;1.6.322: java.text.ParseException: inconsistent module descriptor file found in 'http://downloads.mesosphere.io/maven/mesosphere/marathon/plugin-interface_2.12/1.6.322/plugin-interface_2.12-1.6.322.pom': bad revision: expected='1.6.322' found='1.6.322-SNAPSHOT';
      

      When I look at the pom, it does indeed contain 1.6.322-SNAPSHOT as the version instead of a release version.

      <modelVersion>4.0.0</modelVersion>
      <groupId>mesosphere.marathon</groupId>
      <artifactId>plugin-interface_2.12</artifactId>
      <packaging>jar</packaging>
      <description>plugin-interface</description>
      <version>1.6.322-SNAPSHOT</version>
      <name>plugin-interface</name>
      

      I, and SBT, expect this version to be a release version => 1.6.322. So I think something went wrong with the release/deployment of this artifact.

       

       

        Attachments

          Activity

            People

            • Assignee:
              ken Ken Sipe
              Reporter:
              yennickt Yennick Trevels
              Team:
              Orchestration Team
              Watchers:
              Ken Sipe, Yennick Trevels
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: