Details

    • Type: Task
    • Status: Accepted
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: Marathon 1.4.1, Marathon 1.4.2
    • Fix Version/s: None
    • Component/s: Docs

      Description

      During testing I went from 1.4.2 -> 1.4.1.   I think they have the same data schema, if so this should have worked.  Regardless the installation of marathon failed with:

      mesosphere.marathon.MigrationFailedException: Migration from Version(1, 4, 2, PERSISTENCE_STORE) is not supported as it is newer than Version(1, 4, 1, LEGACY).
      

      There is No feedback to the end user.  It is required that they dig into logs to uncover this.  Most important I don't know if we have a policy or instructions on downgrading or rolling back.

       

      There are at least 2 issues here:

      1. Provide proper failure message to end user
      2. Document the downgrade policy and procedure
      3. if the schema is the same schema... then it should have worked.

       

       

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ken Ken Sipe
              Team:
              Orchestration Team
              Watchers:
              Aleksey Dukhovniy, Karsten Jeschkies, Ken Sipe
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: