Resolution: Won't Do
Affects Version/s: None
Fix Version/s: None
Component/s: Storage Volumes
Renaming after other big changes (to avoid conflicts):
- [ ]
MGI-3455adds the possibility to wipe task state in order to free reserved resources. The underlying implementation in not fully tested – write a decent IntegrationSuite for that!
- [ ] Adjust package structure and names in general. Update the Docs on Architecture (names, flow)
- [ ] Maybe subdivide TaskStateOp into two sub sealed traits: NewTaskStateOp, ChangeTaskStateOp. Then implement Task.update only for ChangeTaskStateOp?
- [ ] TaskStateOp.LaunchEphemeral contains a Task while it should expect a Task.launchedEphemeral.
- [ ] rename QueuedTaskCount.taskLaunchesInFlight to taskOpsInFlight --> 1h
- [ ] Rename LocalVolume_ to PersistentVolume_ where applicable. We decided to speak of Local Volumes and Network Volumes instead of Persistent and External volumes, respectively. However, we should use the naming of the underlying Mesos features throughout the code and only use official naming in the API layer – otherwise it's hard to draw the line somewhere else. --> 1h
- [ ] Rename TaskOpFactory to TaskOpMatcher. TaskOpFactory.buildTaskOp to matchRequest.
- [ ] Remove traits TaskCreationHandler and TaskReservationTimeoutHandler
- Rename TaskCreationHandlerAndUpdaterDelegate to TaskStateOpProcessorImpl
- adjust the tests (this is the main effort here)
- [ ] Get rid of TAskStateOp.possibleNewState – it's only used in the AppTaskLauncherActor and None in case of a LaunchedOnReservation
- [ ] Clearly distinguish between TaskOp/TaskOpProcessor and TaskStateOp/TaskStateOpProcessor. Maybe the former can be renamed to something related to Offer since it's output is related to OfferOperations (mostly everything in Marathon is related to tasks anyway)